key Войти Валюта:
calendar 28.03.2016
heart 665
question Комментариев: 0

Установка Apache+PHP предполагает, что пользователь получит PHP 5.3. Для установки версии 5.6 необходимо подключить репозитории:

EPEL:

rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm

Webtatic:

rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm

После подключения репозиториев можете переходить к установке PHP 5.6:

yum install php55w

Чтобы проверить, какая версия PHP установлена на сервере, воспользуйтесь следующей командой:

php -v

Создайте файл /var/www/html/info.php:

nano /var/www/html/info.php

Добавьте в него текст:

<? phpinfo(); ?>

Откройте файл /etc/php.ini в режиме редактирования:

nano /etc/php.ini

Исправьте Off на On в строке short_open_tag (нажмите Ctrl+W, чтобы упростить поиск):

short_open_tag = On

Перезагрузите сервер:

service httpd restart

Откройте в браузере ваш-IP/info.php:

soc-1
Tweet
© СХОСТ. All Rights Reserved.